Anakin's Lightsaber

FOLLOWERS

152

LIKES

This is a replica of Anakin Skywalker's lightsaber as seen in Star Wars Episode III. Please note that the lightsaber stand is not included in the digital model.
Login to hide ads!

MOC-23054

Name Anakin's Lightsaber
Designer SwanDutchman
Designed 2017
Inventory 236 parts
Theme Star Wars

4 COMMENTS

  • 3 weeks, 5 days ago NewEngland Level 5
    Pretty awesome MOC! One thing though:
    The technic axle that connects the center section to the top and bottom sections doesn't fit through the small hole in the center section. You can shove it in, but It creates unnatural stress on the pieces. Is this how it's suppose to be? Without the axle, the model is very fragile. 
    • 3 weeks, 5 days ago SwanDutchman Level 10 Designed this MOC
      Thank you! There should be no stress on the pieces. The axle fits precisely (make sure it goes through straight). If I remember correctly I did not shove the axle through the center section, but instead built the center section around the axle. That can be a little bit tricky, but once all the parts are there it should be very strong.
      • 3 weeks, 3 days ago NewEngland Level 5
        Alright, I will take a look. Also are the black strips supposed to be loose? I'm currently trying to find a way to lock the bottom portion of the hilt so they stay in place.
        • 3 weeks, 3 days ago SwanDutchman Level 10 Designed this MOC
          It should be pretty solid. Every black stripe is connected on 2 points. They are connected to the 4x4 round bricks which turn 45 degrees each time (use the hide button to see that).
          On the inside of the bottom there are 2 bars going through. I noticed that studio detects collision on this point making them invisible. Just turn off collision detection to see them. Having built this myself in real I am confident it works out fine.
to your account to add or reply to comments.
Already have some of the parts? Use the Build this MOC page to only show the parts you are missing.
Create an account to change the default filters used.

Waiting for Inventory to load